funny image of alpine

A forum for general discussion about Linux. If it is about Linux, but does not seem to fit in any other forum, then this is probably the best place to post it.
Post Reply
bigpod
Posts: 28
Joined: Thu Jan 02, 2020 7:51 pm

funny image of alpine

Post by bigpod » Fri Jan 03, 2020 1:49 pm

Image

now this is funny
Use whatever tool makes your job easier.

User avatar
DistroTube
Site Admin
Posts: 49
Joined: Thu Jan 02, 2020 1:12 am

Re: funny image of alpine

Post by DistroTube » Fri Jan 03, 2020 4:24 pm

I wonder about compatibility problems with a distro that rips out the GNIU coreutils, especially if you have a lot of scripts that invoke coreutils.

User avatar
Trigex
Posts: 9
Joined: Thu Jan 02, 2020 6:41 pm

Re: funny image of alpine

Post by Trigex » Fri Jan 03, 2020 6:24 pm

DistroTube wrote:
Fri Jan 03, 2020 4:24 pm
I wonder about compatibility problems with a distro that rips out the GNIU coreutils, especially if you have a lot of scripts that invoke coreutils.
Alpine uses busybox which is pretty popular and not too incompatible with the GNU coreutils, flags missing here and there sort of deal. A lot of bash scripts probably won't work, since people who tend to write bash scripts tend to use all the GNU coreutils niceties (and it doesn't actually have bash I think lol), but I'll take a bet you won't ever run into issues with running most POSIX compliant shell scripts. Same sort of deal here with the BSDs!
ImageImage

User avatar
xeriab
Posts: 2
Joined: Sun Jan 19, 2020 2:17 am

Re: funny image of alpine

Post by xeriab » Sun Jan 19, 2020 3:19 am

DistroTube wrote:
Fri Jan 03, 2020 4:24 pm
I wonder about compatibility problems with a distro that rips out the GNIU coreutils, especially if you have a lot of scripts that invoke coreutils.
That's why I am migrating my whole configurations and shell scripts to POSIX compliant; after I forced my Arch to use Dash instead of Bash I had to alter some scripts and packages. but everything GNU related thing is getting updated it breaks the whole setup. specially (Autoconf and its sisters) so I had to freeze/prevent some packages from update so my system won't break :D
31 y.o. Geek, Nerd, Developer and Metal head from Yemen. 😑

Post Reply