did i kill my USB stick using CP?

A forum for general discussion about Linux. If it is about Linux, but does not seem to fit in any other forum, then this is probably the best place to post it.
Post Reply
User avatar
Posts: 5
Joined: Sun Jan 19, 2020 10:30 am

did i kill my USB stick using CP?

Post by tuxito » Tue Jul 14, 2020 3:33 pm

Hi there,

I have more than one computer at home. one of them is running mint 19.3. I planed to push it to LM20. So Sunday i downloaded the iso. I used the "cp" method to make my usb bootable. Method i found there: https://wiki.archlinux.org/index.php/US ... _utilities
I used it in a laptop. It takes a while to be down. An during this period of time, someone came to visit. Unfortunatly the laptop was not plugged and powered off in a bad way. I did not presence it but i suppose the shutdown happened during the "cp" command. But i can't be affirmative.

Now the problem is when i wanted to check if the iso was fine. I couldn't see my usb stick in the lbslk command. It was simply invisible. fdisk -l had the same outcome.
i checked through dmesg and i can see the usb pluged. I see it as well when using lsusb.

I tried to play it smart. I tried to used the different methods (in the link above) by using the /dev/bus/usb/002/005 (*) but not a chance.

When i try to mount it, the terminal returns that /dev/bus/usb/002/005 it is not a block device.

i tried to change the usb port, i even tried in a different computer.

So, after so much information is my usb pen drive dead? or is it something i can do to save it?

Thank you for reading.

(*) here it is just an example path, the point is i tried to go around the fact /dev/sdb is not available but "bus" was.
Penguins have been chicks and chicks have been eggs, newbie, be patient and practice and you'll be a linux power user some day.

Post Reply